We recommend Google Chrome, but current versions of Firefox, Safari, Edge, and Internet Explorer are also supported.

The required browser versions are:

Did this answer your question?